Back to overview
Resolved
Service Disruption – Clausius & Kelvin Applications
Aug 25, 2026 at 9:41am UTC
Affected services
SeltronHome API
Clausius
Kelvin
Resolved
Aug 27, 2026 at 2:26pm UTC
Issues were successfully resolved, Applications are back to working normally
Affected services
Created
Aug 25, 2026 at 9:41am UTC
We are currently experiencing a service disruption affecting the ability to add service technicians and users within the Clausius and Kelvin applications.
Our team is aware of the issue and actively working on a resolution. We apologize for any inconvenience this may cause and will provide updates as more information becomes available.
Affected services